Results 1 to 6 of 6

Thread: Can't Host Servers Anymore After Buying new Router

  1. #1

    Unhappy Can't Host Servers Anymore After Buying new Router

    Hello guys i have been away from the forum for a very long time because everything used to work like butter smooth by the time i had an experience to fix almost every single issue i faced with MOHAA hosting and the ports but this time i have no clue at the Past I Had Unlocked Router Called "Huawei HG531 v1" it was working as ADSL2+ anyway Hosting Mohaa Was Perfect as soon as i run MOHAA_server.exe the server appears instantly and i can even join it by using the public IP.
    to cut the chase The Land Lines were all converted to Fiber instead of Copper So i had to change my router to VDSL Router now I Have "TP-Link Archer VR300 v1.20" and it is working as VDSL2 at least this is what the router says in "DSL Modulation Type" Box.anything else work perfectly all ports can be open tested it with portforward and other software.
    but for some reason Mohaa is totally blocked. i can still join my server on LAN. any idea what is going on?
    i hesitated to write this because i didn't want to look dummy i just can't figure it out after i kept searching for a very long time and applied many different methods but with no luck.
    do i need to change anything inside my router? do i need to add any options to my server script? i ran out of ideas
    is this really it? there is nothing i can do but to change the router again? TBH i doubt that i can do that since these things don't come cheap in my country.

    OS: Windows 10 Pro Version 2004 without any external security suits or firewalls.
    this is my server setup:
    //Basic Mohaa v1.11 Server settings:
    seta sv_hostname "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
    //seta sv_hostname "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
    seta net_noipx "1"
    seta net_noudp "0"
    seta sv_gamespy "1"
    seta g_gametype "1"
    seta sv_maxclients "12"
    seta sv_maxrate "7000"
    seta timelimit "15"
    seta fraglimit "0"
    seta g_teamdamage "0"
    seta g_inactivekick "0"
    seta g_inactivespectate "0"
    seta sv_master1 ""
    seta sv_master2 ""
    seta sv_master3 ""
    seta sv_master4 ""
    seta sv_master5 ""
    seta rconpassword "xxxxxxxxxx"
    //seta sv_privateclients "0"
    //seta sv_privatepassword "xxxxxxxxx"
    seta sv_floodprotect "1"
    seta sv_allowdownload "0"
    seta sv_timeout "240"
    seta g_allowvote "0"
    seta sv_pure "0"
    seta sv_precache "1"
    seta sv_runspeed "275"
    seta dmflags "8"
    seta sv_maplist "dm/mohdm6"
    //Log setatings:
    //seta developer "2"
    //seta chat "1"
    //seta g_log "qconsole.log"
    //seta sv_chatter "1"
    //seta logfile "3"
    //seta g_logsync "1"
    //Basic Mohaa v1.12 Patch Server settings:
    seta sv_stufftextdetection "0"
    seta sv_recoilemulation "1"
    seta sv_antistwh "1"
    seta sv_antiwh "1"
    seta sv_banning "1"
    seta sv_kickbadcmd "0"
    seta sv_kickping "300"
    map "dm/mohdm6"
    and i use this command line parameter:
    "X:\Games\Medal of Honor - Allied Assault War Chest\MOHAA_server.exe" +set net_ip "" +set net_port "10001" +set net_gamespy_port "10002" +set net_qport "10003" +exec "serv2014.cfg"
    i don't use the patch but i use Hosts file to fix the server browser:
    Last edited by just-user; June 14th, 2020 at 05:21 AM.

  2. #2

    Default is the master server these days. Maybe that's the whole problem.
    Browse MOHAA Servers Post GameSpy Era


    Medal of Honor: Game Server Browser Fixer - Patches your MOHAA, MOHSH, and MOHBT game binaries to allow you to retrieve a list of game servers within the multi-player menu in-game even after GameSpy ceases operation!

    Medal of Honor: Query Launcher - Find, browse, organize, join, get your ping, and get more information regarding all Medal of Honor (AA, SH, & BT) servers from your PC at any time!
    Medal of Honor: Web Server Master List - Find and browse all Medal of Honor servers online using your browser!
    Add your Medal of Honor Server to the Master List
    YouTube Video for Medal of Honor: Query Launcher and MOHAASERVERS.TK!

    MOHAA Mods and Utilities
    OwN-3m-All's Mods
    Make Me Stock - A program that allows you to easily move-in and move-out non-stock mods and other files at the click of a button. Automates adding / removing mods without having to copy / move files manually.

    Quality Game Servers

    Rent dedicated Dallas Texas, Kansas City, Las Vegas Nevada, Chicago, Pennsylvania, and Sofia Bulgaria MOHAA and other game servers from We Be HostiN starting at $10 a month.

  3. #3


    On the net_ip cvar dont set nothing, let the game pick the ip.

    The gamespy port should be 1098 because the masterserver calculate with the server default port + 97.

    And dont set the server qport too.

    With this test again to see if someone can join.

  4. #4


    still the same always timeout any more ideas?

  5. #5


    Join the x-null discord so we can help you with this problem.

  6. #6


    problem solved on discord thanks to all reborn staff.
    here is some guidelines for the people who face the same issue:
    1- as own3mall said above use as the master server inside your hosts file.
    2- if you can't see your server inside the game browser you can should be able to see it there
    3- if you can't join using your public server IP address use your local server IP address AKA LAN instead.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts