Results 1 to 5 of 5

Thread: [Solved] Spearhead dedicated server help

  1. #1
    Senior Member Major A's Avatar
    Join Date
    Aug 2014
    Location
    Indiana, USA
    Posts
    108

    Default [Solved] Spearhead dedicated server help

    This is going to sound dumb, but I am stuck.

    The guys who let me run my spearhead server on their machine got a new setup.

    It's running windows 7 enterprise

    I have ports forwarded with Port forwarding Wizard
    12203-12218 UDP
    according to port checker tool, they are forwarded and open

    Also program is allowed through firewall

    The server console gives me this and I cannot connect to the server

    Code:
    Winsock Initialized
    Opening IP socket: 47.50.185.238:12203
    WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL
    Opening IP socket: 47.50.185.238:12204
    WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL
    Opening IP socket: 47.50.185.238:12205
    WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL
    Opening IP socket: 47.50.185.238:12206
    WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL
    Opening IP socket: 47.50.185.238:12207
    WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL
    Opening IP socket: 47.50.185.238:12208
    WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL
    Opening IP socket: 47.50.185.238:12209
    WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL
    Opening IP socket: 47.50.185.238:12210
    WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL
    Opening IP socket: 47.50.185.238:12211
    WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL
    Opening IP socket: 47.50.185.238:12212
    WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL
    Opening IP socket: 47.50.185.238:12213
    WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL
    Opening IP socket: 47.50.185.238:12214
    WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL
    Opening IP socket: 47.50.185.238:12215
    WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL
    Opening IP socket: 47.50.185.238:12216
    WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL
    Opening IP socket: 47.50.185.238:12217
    WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL
    Opening IP socket: 47.50.185.238:12218
    WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL
    WARNING: Couldn't allocate IP port

    I've never seen this issue before.
    If I run as admin or not makes no difference.
    winxp compatibility mode makes no difference.

    So, I'm stuck on what to try next.
    Last edited by Major A; January 18th, 2020 at 06:08 PM.

    MSI B85M-G43 * Dualcore 3.3GHz * 12GB ram * GT740 4GB video * Logitech USB Marble Mouse=Trackball * System - ArchLinux-EndeavourOS, KDE Plasma Desktop * Triple monitor

  2. #2

    Default

    Firewall issue. Also did you open TCP Ports too?

  3. #3

    Default

    Seems like the game dont have permissions to open a port on the firewalll.

    Check on the executable if he have the system permissions.

    If that dont work you can speak with me on the TS later to see if i can help you more.

  4. #4
    Senior Member Major A's Avatar
    Join Date
    Aug 2014
    Location
    Indiana, USA
    Posts
    108

    Default

    ok I'll give that a shot next I mess with it thanks.

    MSI B85M-G43 * Dualcore 3.3GHz * 12GB ram * GT740 4GB video * Logitech USB Marble Mouse=Trackball * System - ArchLinux-EndeavourOS, KDE Plasma Desktop * Triple monitor

  5. #5
    Senior Member Major A's Avatar
    Join Date
    Aug 2014
    Location
    Indiana, USA
    Posts
    108

    Default

    Just an update
    actually found 2 things wrong

    For whatever reason, the shortcut for the server no longer likes +set net_ip 47.50.185.238 inside it.
    That was causing the error
    Code:
    Opening IP socket: 47.50.185.238:12203 WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL
    Only need to specify the port number.

    second had something to do with new router on his server and did not
    like the way the ports were fwded.

    solved.

    Added to server list @ http://www.mohaaservers.tk/

    Just waiting for them so show in ingame browser, as they have not yet.

    MSI B85M-G43 * Dualcore 3.3GHz * 12GB ram * GT740 4GB video * Logitech USB Marble Mouse=Trackball * System - ArchLinux-EndeavourOS, KDE Plasma Desktop * Triple monitor

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •