Results 1 to 10 of 10

Thread: MOHAA to Q3

  1. #1

    Default MOHAA to Q3

    G'day, I'm trying to create a 3D model from MOHAA brushwork.
    I don't have the third party programs mentioned by Zappa in the other thread (Stalingrad) so I'm following an alternative that I found some time ago, here
    This method creates an ASE file which can be imported by LightRay3D then export as a skd.

    I've followed the preparation steps:
    To do this, select, copied or created the initial brushwork that needs to be converted into a model, surround it with a 'caulk hull' box, the box should encase the object on all sides and be sealed with no gaps or openings present. Place an info_player_start inside the box, it doesn't matter where so long as it doesn't intersect or get in the way of any brushwork or the caulk hull. Make sure to correctly position the brushwork object relative to the 0,0,0, grid centre point as shown below, remove any game related entities and un-group any brush based entities so they become raw brushes again. Save the file as a *.map.

    Centre brushwork appropriate to the intended use of the model

    Remove all game related entities except info_player_start

    Texture only the faces you want converted

    Caulk all unseen and unwanted faces

    Use info_player_start entity only, not another player or ai spawn marker

    Break brush based entities back into normal brushwork

    Place a caulk box around selection

    Make sure there are no gaps or leaks

    Using MOHAA Radiant, I saved the desired area of brushwork from my MOHAA map as a prefab.
    I then opened a new map and imported that prefab.
    After centering it in all three views I then surrounded it closely with caulk brushes to form a box and added an info_player_start entity inside.
    I then saved that as a map.

    I have copied the map of my proposed model to the Q3A/maps/dm folder and opened GTKRadiant.
    It is listed in GTKRadiant "File/Open" menu but when the map is selected it doesn't load.
    The 2D grid and 3D window are both still empty. However it lists all of the textures used.

    When I select "File/Import" it isn't listed.
    The only import options are ".map" or ".reg"
    I don't see any menu item to import prefab or I'd create the map again in Q3A.

    Is there something I must change manually in the map file using a text editor for it to read as a Q3A map?

    Thank you.

    P.S. I'll be away for a few hours so I'm sorry if I don't answer any reply sooner.
    Last edited by AccadaccA; December 20th, 2019 at 03:41 PM.

  2. #2


    If the map have detail brushes, convert them to structural, or open the map file with a text editor, select all the "+surfaceparm detail" and delete them

  3. #3


    Thanks Zappa mate, but it's not the issue.
    Before I even select a map to open GTKRadiant shows this error at the bottom of screen.
    Unable to find default tag file C:/Program Files (x86)/GtkRadiant 1.5.0/ No tag support.
    Sorry I didn't notice it yesterday when I posted.

    Then when I do select the map file it prints out the following:
    Loading map from C:/Q3A/baseq3/maps/
    Open file C:/Q3A/baseq3/maps/ for read...success
    Texture load failed: "textures/"
    Loaded Texture: "textures/common/caulk"
    Loaded Texture: "textures/crane_boom/greenhopper1c"
    map load timer:  0.03 second(s) elapsed
    --- LoadMapFile ---
    192 primitive
    2 entities
    I copied the caulk.tga and it's shader from MOHAA as I couldn't find caulk in Q3A pak files.
    Another thing is that the last line says "2 entities" when there is only one, the info_player_start.

    I'll attach the pk3 if anybody wants to take a look at it for me.

    edit: updated attachment.
    Attached Files Attached Files
    Last edited by AccadaccA; December 21st, 2019 at 01:54 PM.

  4. #4


    Whoops. Hang on. I may have figured it out.

    I updated the pk3 with the caulk texture and shader but not the map itself.


    It hasn't made a difference. GTKRadiant still produces the same output text and the map is invisible.
    Last edited by AccadaccA; December 21st, 2019 at 01:49 PM.

  5. #5


    No need to include the caulk shader, it already exist in Q3

    I tried to load your map (without the custom caulk) and it loaded just fine, no errors at all

    Loading map from C:/Program Files (x86)/Steam/steamapps/common/Quake 3 Arena/baseq3/maps/
    LOADED: textures/common/caulk
    LOADED: textures/crane_boom/greenhopper1c
    --- LoadMapFile ---
    C:/Program Files (x86)/Steam/steamapps/common/Quake 3 Arena/baseq3/maps/
      192 brushes
        1 entities
     0.09 second(s) load time
    I noticed you are using GtkRadiant 1.5.0
    I'm using the latest GtkRadiant 1.6.6
    maybe that's the problem

  6. #6


    Zappa: Thanks for taking the time to check it out, mate.
    Strange, I have two installments of the game and nether have caulk in any pk3... Unless I've gone totally blind. It's possible. lol
    It's not so much a "custom caulk" but rather the exact caulk used in MOHAA, which I suppose is "custom" to Q3.
    I'll give GTKRadiant 1.6.6 a go and holler at you if things continue to go south.

    Thanks for the link too, mate.

    ..... a short time later ......

    Whoohoo! The map file loaded as is (with caulk texture & shader), no probs.

    Much appreciated Zappa. Thank you.

  7. #7


    I saved the map using GTKRadiant 1.6.6 and continued following the instructions found on
    It was pretty straight forward. Only three setup steps to compile into a bsp with Q3map2Toolz then another four setup steps to convert to ASE.
    LightRay3D (version v1.4.0) took forever trying to import the file.
    "ASE Importer - Reading File" for more than ten minutes. Then I closed LightRay.

    MilkShape (version 1.8.5) doesn't support the ASE format.

    Downloaded and installed Blender (version 2.81a)
    Blender doesn't support the ASE format.

    Deleted the MOHAA caulk and shader from my pk3.
    There's now a couple of new pk3 files in my "Quake3Arena\baseq3" folder, one with "caulk.tga" in it, since installing GTKRadiant 1.6.6.
    "common-spog.pk3" <<< this one has (pink) "caulk.tga"

    Went back to GTKRadiant 1.6.6 and replaced the info_player_start (the original was from MOHAA Radiant).
    Saved the map and noticed that GTKRadiant 1.6.6 has an option in the BSP menu "ASE: convert to ASE model".
    It's also in the "Project Settings"; "bsp_ASE: convert to ASE model" to add it to the BSP menu if not already there.

    Renamed the first ASE file so as not to overwrite it. Dunno why, I'm just a hoarder. heh
    Compiled using Q3maps2Toolz.
    Tried the built-in converter found in GTKRadiant.

    Copied the ASE file to LightRay's "Objects" folder and tried importing into LightRay3D again. Nudda.
    Ate dinner, fed the dog, made a cup of coffee then closed LightRay after a good 15 minutes of it trying to import.

    Rinsed and repeated.
    Used Q3maps2Toolz to convert the updated bsp.
    Copied the ASE to "Lightray3D/Objects" folder... etc.

    BTW, they're all the latest versions of 3D modelers. LightRay claims to have a 1.5 beta but the download is version 1.4

    *sigh* :/

    Thinking to rename the MOHAA map from "loop" to "cursed".

  8. #8


    I converted it same way I converted the stalingrad map

    Now, because of the way the brushes are converted and the shape of them, the model ended with 3504 vertices and 700 mesh objects
    so you will need to attach (Modify tab > Edit Mesh) as many meshes as you can without exceeding the 1000 vertices per group limit

    doing this is a very slow and boring process, and if this is your first time doing this in Lightray it can be very frustrating, but is the only way to do it, because of the vertices limit in the game

  9. #9


    Zappa: Thank you for your time and effort, I really appreciate it.
    It's frustrating that it didn't work for me as I don't want to be relying on others.

    What makes it worse is that I used to make car models from scratch for Need For Speed using just a simple cad tool.
    Simply create vertices at the cursor and play join-the-dots to form the polygons.
    Load your desired TGA file and drag the model part over it to do the the texture mapping.
    No spheres, cubes or bloody pyramids in the program at all. Everything was basic and straight forward.
    Unfortunately that cad tool is no longer on the net and the modelers today are so complex.

    I opted for the KatsBits method simply because you mentioned requiring Windows 10. I loath it with a passion.
    Window 10 is the biggest Trojan the world has ever seen and I have two dead HDDs with it installed. My newest HDDs at that.
    The most recent took 2.5 hours to update then it rolled over and died. Boots as far as the blue screen of death and none of the options fix it.
    The OS installation was less than two weeks old after the install before that died and it only had one game on it, ARK (via Microsoft Store), plus a web browser. No other other programs.
    Similar to the previous Win 10 HDD, it only had Sea of Thieves (via Microsoft Store) on it, plus a web browser and OBS to capture game footage.
    I assume it was an update in the background as the failures were always when booting up first thing in the morning.

    Admittedly the Windows 10 ISO I have was the free version from the Microsoft website but I was reinstalling it every few weeks because it would simply stop functioning. Happened on both new HDDs.
    I guess the time has come for me to start watching Maverick and take midday naps. lol

    Thanks again for you help.

  10. #10


    well, windows 10 is not a must. you can still convert fbx files with other tools (e.g.

    you can also try Ley0k's converter

    or you can keep trying with the KatBits method.
    If you ask google the right questions, eventually, you will figure out how to make things work

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts