Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Game crashes when shooting in custom map

  1. #1

    Default Game crashes when shooting in custom map

    G'day folks, I've had this one before in another map and it's apparently a known issue, so I'm told.

    The map plays fine except when I try to shoot.
    I have no idea when this started as I normally holster my weapon whilst testing.

    Your help will be appreciated. Cheers

  2. #2


    That is a very strange bug.

    On console dont show any error?

  3. #3


    Yeah every time I run the game it's starts with "MOHAA console doesn't have a localization entry"... something or other and I have to click the screen then hit Esc to get all that gibberish off my screen.
    It's rather annoying actually.

    With the map, the console scrolls that fast I can't see the first part of it, even when I scroll back up.
    I forget how to save it.

    Shadow told me that it was a common known bug a few months ago when it happened to another map of mine.
    I mean it plays fine except when you shoot it hangs.... forever.

  4. #4


    You maybe have the developer mode on.

    Try put him 0 to see if dont crash.

  5. #5


    The localization error messages are something completely normal
    you can bypass them writting this on the last line of your "global/localization.txt" file

    { "&&&" "&&&" }

    Regarding your problem. Are you sure you are not using custom animations or a modified mike_torso file?
    and in what maps do you have this issue?

  6. #6


    DoubleKill: Yeah mate, developer mode was on but it has made no difference turning it off.
    Thank you all the same.

    Zappa: Thanks mate, but I don't even have the default "global" folder in either Revival or War Chest installations.
    I did create one some time ago but that was for a custom map. Otherwise it wouldn't exist.
    There is certainly no "localization.txt" file in either installments of the game.

    The closest it comes to is "localize.cfg" found in the main folders of the expansions.
    mainta: (both "Revival" & "War Chest")
    // Default options for localization.
    seta g_subtitle "0"
    seta ui_moviesubtitle "0"
    maintt: (both "Revival" & "War Chest")
    // Default options for localization.
    seta g_subtitle "0"
    seta ui_moviesubtitle "0"
    seta ui_hostname "Nameless Battle"
    Nothing at all in AA which is where I test to ensure it's compatible for all players.
    I searched all folders of "main" and the "MOHAA" root folder itself.

  7. #7


    Sorry Zappa, I failed to answer your questions.

    Although I haven't introduce any new animations I do have re-skinned versions of the "commontree" and the opel truck. Both of which do have animations.
    The truck is idle and it works well (re-skinned) in another map, so it can't be that. I've just tested it, firing rounds without a crash.
    I am pretty sure that I have shot a few rounds at windows in this map since adding the trees. I'll remove them anyway and try again.
    Although, having said that, the other map it happens to doesn't have any trees and only a few default models (covered light bulbs and coronas).

    BTW, I am definitely not using "mike_torso". I couldn't fit my beer gut in it if I tried. lol
    The map is a new one, made from scratch (only half built).
    There are no dead bodies or any bots.

  8. #8


    Okay I have narrowed it down to something I've done either yesterday or the day before.
    Previous version saves from three days ago work fine with trees, trucks and shooting.
    So it's not animation or anything related to the re-skinned models.

    Dang. All I've done in the past three days is build with brushes and add lights to the new buildings.
    Is there a limit on patches? I do have quite a lot around the map, especially in one area.

  9. #9

    Thumbs up

    I've got it. (happy happy, joy joy)

    It was a custom texture causing the hang when you shoot.
    Strange but true.
    What's even stranger is that it worked with the whole two-story building covered in that brick texture but as soon as I replaced the matching brick extension (extra room on ground floor) the game would hang.

    It's like I could use X amount of this texture but not X amount + 1.

    The shell of that building and extension have been in the map for a month without any glitch. Just with a different texture, without windows, rooms, stairs or lights.
    As you can imagine this done my head in for some time. lol Working after one compile but not the next.
    I was back and forth removing and replacing two buildings before trying the second one without it's lower floor extension and back fence. Surprisingly I was able to shoot without crashing the game.
    Everything is now back as it was yesterday, just textured with a different brick texture. Both buildings, the extension, the fence, my power-lines, all good .

    Now that I know the cause I can get my other map working again too. Yay lol

    Thanks DoubleKill and Zappa for your attempts to rectify this issue.
    Much appreciated guys.

  10. #10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts