Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Log File Default Location Linux

  1. #11

    Default

    Here's what I posted:

    http://ubuntuforums.org/showthread.php?t=2064888

    No one offered any relevant solutions that would actually work. Is there anything we can do?

    I can't get these settings to work in the log parameters... can anyone else try this and see if they can get the logfile for the server to write out to another file and into another directory?

    Here's one I tried, but did not work:
    Code:
    //Logging
    seta logfile "3"
    seta developer "1"
    seta g_logsync "1"
    seta fs_basepath .
    seta logfilename "qconsole.log"

  2. #12

    Default

    I have the same problem
    could do something about it @ own3mall


  3. #13
    Purple Developer Purple Elephant1au's Avatar
    Join Date
    Feb 2012
    Location
    Australia
    Posts
    1,240

    Default

    Hey all,

    I can get my logfiles working to a custom directory in Linux ( Ubuntu and CentOS )
    You need to set the fs_outputpath and logfilename

    The game server will automatically append "main" to the end of whatever this cvar's value is. In my case the log file will be created in:

    /home/purple/.mohaa/main/

    Next, type this in the game server console:

    logfilename

    If you haven't overriden this setting it should echo back this:

    "logfilename" is:"server1.log" default:"qconsole.log"

    The game server puts these two pieces together in order to form the fully qualified path to the log file. In our example, the file created will be this:

    /home/purple/.mohaa/main/server1.log

    KEY POINT
    I can only seem to get these commands to work if you set them in the startup commandline.
    ./mohaa_lnxded +set dedicated 1 +set ui_console 1 +set net_IP x.x.x.x +set net_port 12205 +set g_gametype 1 +set fs_outputpath "/home/gs/servers/logfiles" +set logfilename "mohTest.log" +map dm/mohdm6 +exec serverTest.cfg

    Purple's Playground
    OBJ :
    103.29.85.127:12203
    xfire: purpleelephant1au
    email: purpleelephant1au@gmail.com
    skydrive: PurpleElephantSkydrive




  4. #14
    Developer Todesengel's Avatar
    Join Date
    Dec 2013
    Location
    St. Louis, Missouri, USA
    Posts
    244

    Default

    Purple - I had the same results. I tried setting up my *nix servers to do logging elsewhere and never got it to work with cvars. It never dawned on me to put them on the command line, which makes sense as it probably starts up logging before parsing server.cfg. Good catch

  5. #15
    Über Prodigy & Developer Razo[R]apiD's Avatar
    Join Date
    May 2010
    Location
    Poland, Lublin
    Posts
    3,226

    Default

    You could also try some stuff with symbolic links

    EDIT: I've read the thread on Ubuntu Forums. I think when I ran mohaa_server on my Debian VM it logged to working directory from which the game was executed. Maybe it is in the end a system setting?

  6. #16
    Developer Todesengel's Avatar
    Join Date
    Dec 2013
    Location
    St. Louis, Missouri, USA
    Posts
    244

    Default

    I did try using symlinks too, but that was when I was using cvars. Now that I know the obvious from purple - use the command line - I'll revisit that.

    I think in the end what I did was just make a special file that was actually a socket, named 'qconsole.log'. When mohaa started, it was more than happy to open the existing special file and write to it. Another process opened the same socket and just read the logfile lines.

    That's an "ok" approach, but far better than trying to read a regular file while the server is writing to it (that way will lose data occasionally no matter what you do). These days, I'm using cvars as ipc slots to pass info to an aribiter process (a mux/demux if you will). That's how I'm getting mohscript access to external prograrms and vice versa these days.

    I can see open inodes of course, maybe tonight I'll translate that inode to a file and path and locate the bugger. I'd like to have logging, given that the coop mod bombs the BT server on startup

    T

  7. #17

    Default

    Quote Originally Posted by Purple Elephant1au View Post
    Hey all,

    I can get my logfiles working to a custom directory in Linux ( Ubuntu and CentOS )
    You need to set the fs_outputpath and logfilename

    The game server will automatically append "main" to the end of whatever this cvar's value is. In my case the log file will be created in:

    /home/purple/.mohaa/main/

    Next, type this in the game server console:

    logfilename

    If you haven't overriden this setting it should echo back this:

    "logfilename" is:"server1.log" default:"qconsole.log"

    The game server puts these two pieces together in order to form the fully qualified path to the log file. In our example, the file created will be this:

    /home/purple/.mohaa/main/server1.log

    KEY POINT
    I can only seem to get these commands to work if you set them in the startup commandline.
    ./mohaa_lnxded +set dedicated 1 +set ui_console 1 +set net_IP x.x.x.x +set net_port 12205 +set g_gametype 1 +set fs_outputpath "/home/gs/servers/logfiles" +set logfilename "mohTest.log" +map dm/mohdm6 +exec serverTest.cfg
    This does work, but it did not solve my problem.
    I have a linux instance, I open a server MOHAA works perfect, I open the second server after 4 or 5 hours the first server drops.
    I thought the problem was because they shared the same folder address.
    I will make a post about the problem with more details.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •